FiFA 19 PC - Cutscenes on Dx 12 are locked to 30 FPS, Again

Sami1999
223 posts Has Potential To Be Special
This was fixed in FiFA 18 with update. Why is it back again?

Cutscenes are locked to 30 FPS on DirectX 12 API as well as on Window mode on both Dx12 and Dx11. This is unacceptable since previous games never had such issues.


Right now, only way to play on unlocked framerate on cutscenes is by playing on fullscreen mode with Dx11 API.


Please fix this issue. Right now it's impossible to play in borderless fullscreen mode with unlocked framerate because of this. Also this is the 2nd time EA made 30 FPS lock on cutscenes on Dx12. Eventually they will stop supporting Dx11 and if they keep locking cutscenes to 30 FPS on Dx12, that means on future titles we might not be able to get 60 FPS cutscenes at all.


Hopefully this gets addressed in the full release of the game.

Comments

  • Placebo_PRS
    210 posts Has Potential To Be Special
    Great post, this needs fixing ASAP, such a mess, this is basic PC development stuff.
  • Alemas_2012
    15166 posts World Class
    Adaptive Vysnc on from the nVidia Control Panel fixes things.
  • Sami1999
    223 posts Has Potential To Be Special
    Adaptive Vysnc on from the nVidia Control Panel fixes things.

    Yeah looks like it does.

    And with normal Vsync, I had to enable "Triple Buffer" on Nvcp as well. I thought it works with only open gl games but it did remove the 30 fps cap.


    But the issue still persists for Amd cards. What EA needs to do is:

    Add FPS lock option separately for cutscenes and gameplay. For example:

    30 FPS lock, 60 FPS lock, Lock to Refresh Rate, Lock to Half of Refresh Rate, No lock.


    ^That solves everything.
  • Sami1999
    223 posts Has Potential To Be Special
    Okay, Window mode on Dx11 still has 30 FPS lock.

    So it's should be fixed. Window mode on Dx12 does work on 60 FPS after forcing Vsync+Triple Buffer from Nvcp.
  • Guys can anyone help me. Im running the game on DX 11 fullscreen mode. I have a GTX 1050ti but still im limited to 30 fps on cutscenes and ingame menus. During the game im getting 60 fps. Please suggest a solution.
  • Sami1999
    223 posts Has Potential To Be Special
    Chinu92 wrote: »
    Guys can anyone help me. Im running the game on DX 11 fullscreen mode. I have a GTX 1050ti but still im limited to 30 fps on cutscenes and ingame menus. During the game im getting 60 fps. Please suggest a solution.

    unknown.png
  • Im on a laptop with 1050ti, tried every game setting(mostly i want ultra, 4x, no limit) every option in nvidia control panel and still not even once got more than 30 fps in menu
  • And i cant find other posts about that is the game even possible to run in the menu more than 30fps
  • Sami1999
    223 posts Has Potential To Be Special
    Mitagki wrote: »
    Im on a laptop with 1050ti, tried every game setting(mostly i want ultra, 4x, no limit) every option in nvidia control panel and still not even once got more than 30 fps in menu

    I don't know if forcing Vsync from Laptop Nvidia drivers work. If it doesn't, then you are pretty much screwed.

    Back in FiFA 15, 16, setting no limit on FPS unlocked the frame rate for cutscenes too regardless of forcing Vsync from Nvcp or not. But now you have to force Vsync else the game just locks itself to 30 fps, kinda ridiculous.

    Anyway, try different settings like Dx11 API + Fullscreen and then force Vsync.


    Keep in mind Dx11 Window/ Borderless window mode does't support unlocked frame rate cause forcing vsync doesn't work.
  • Sami1999 wrote: »
    Chinu92 wrote: »
    Guys can anyone help me. Im running the game on DX 11 fullscreen mode. I have a GTX 1050ti but still im limited to 30 fps on cutscenes and ingame menus. During the game im getting 60 fps. Please suggest a solution.

    unknown.png

    Where is this ?
  • Sami1999
    223 posts Has Potential To Be Special
    sametsefsf wrote: »
    Sami1999 wrote: »
    Chinu92 wrote: »
    Guys can anyone help me. Im running the game on DX 11 fullscreen mode. I have a GTX 1050ti but still im limited to 30 fps on cutscenes and ingame menus. During the game im getting 60 fps. Please suggest a solution.

    unknown.png

    Where is this ?

    Right click on desktop and select Nvidia Control Panel.

    Then go to 3D settings> Manage #D settings> Program Settings> Browse FiFA 19 exe and then force Vsync+Triple Buffer ot force Adaptive Vsync.

    That is if you got a Nvidia GPU. For AMD GPUs its different and I don't know how to do it since I don't have an AMD GPU at the moment.
  • Placebo_PRS
    210 posts Has Potential To Be Special
    Fortunately it's now resolved on AMD, set to Enhanced Sync in Radeon Settings and Frame Rate Target Control set at 60fps, no FPS lock in Fifa settings and everything is 60fps now.

    There was a bug where there would suddenly be a lot of lag in the game when locking the FPS this way but that was fixed with the first title update.
  • Sami1999
    223 posts Has Potential To Be Special
    Fortunately it's now resolved on AMD, set to Enhanced Sync in Radeon Settings and Frame Rate Target Control set at 60fps, no FPS lock in Fifa settings and everything is 60fps now.

    There was a bug where there would suddenly be a lot of lag in the game when locking the FPS this way but that was fixed with the first title update.

    Ah, nice.
  • Loyd_B
    1 posts Ball Boy
    Sami1999 wrote: »
    Fortunately it's now resolved on AMD, set to Enhanced Sync in Radeon Settings and Frame Rate Target Control set at 60fps, no FPS lock in Fifa settings and everything is 60fps now.

    There was a bug where there would suddenly be a lot of lag in the game when locking the FPS this way but that was fixed with the first title update.

    Ah, nice.

    Dude you are my hero, now i have 60+ fps. Thank you <3
  • Placebo_PRS
    210 posts Has Potential To Be Special
    Me or Sami? We need clarification ;)
  • Sami1999
    223 posts Has Potential To Be Special
    Me or Sami? We need clarification ;)

    lol when I quoted you, he probably thought I'm the one who made that comment xD [Unless he meant about Nvidia GPU solution].

    Anyway, good to see we can finally run FiFA at unlocked frame rate on both Nvidia and AMD GPUs.

    Can you do me a favour? See if Enhanced Vsync unlocks frame rate on Window mode with Dx11. With Nvidia cards it doesn't work
  • BSDShoes
    1601 posts Play-Off Hero
    edited October 2018
    Sami1999 wrote: »
    Me or Sami? We need clarification ;)

    lol when I quoted you, he probably thought I'm the one who made that comment xD [Unless he meant about Nvidia GPU solution].

    Anyway, good to see we can finally run FiFA at unlocked frame rate on both Nvidia and AMD GPUs.

    Can you do me a favour? See if Enhanced Vsync unlocks frame rate on Window mode with Dx11. With Nvidia cards it doesn't work

    It does with my AMD card, but cutscenes are still 30-45fps for some reason.

    EDIT- nevermind, graphics settings were too high, can get 60fps in cutscenes in windowed on AMD. I also have a 1070Ti in my simracing rig, might give that a go sometimes.
  • Sami1999 wrote: »
    Adaptive Vysnc on from the nVidia Control Panel fixes things.

    Yeah looks like it does.

    And with normal Vsync, I had to enable "Triple Buffer" on Nvcp as well. I thought it works with only open gl games but it did remove the 30 fps cap.


    But the issue still persists for Amd cards. What EA needs to do is:

    Add FPS lock option separately for cutscenes and gameplay. For example:

    30 FPS lock, 60 FPS lock, Lock to Refresh Rate, Lock to Half of Refresh Rate, No lock.


    ^That solves everything.

    Ran into this problem on Fifa 19 PC while trying to play in my preferred camera angle - PRO.

    PC Specs
    Windows 10 Pro N 64-bit 1809
    Gigabyte G1 Z170X Gaming 7 Mobo rev 1.0
    EVGA FTW3 GTX 1080ti
    i7 6700K @4GHz
    16GB DDR4 3000MHz RAM
    Asus ROG PG278Q 144hz
    Vizio Native 2160 50" Smart TV 60hz @4k 120hz @1080p (test screen with initial issue)

    I had all settings at ultra per default and was using Dx12 getting 30fps in menus and at cutscenes. Eventually during gameplay in regular matchds using Pro Cam. I adjusted settings to high, msaa 2x and still same result. This is my TV with a 60 hz refresh rate. Could have tried the 59hz old school trick but thats usually my last resort.

    Enabling Triple Buffer via Nvidia Control Panel allowed fps to go back to 60 again! Thnx
  • I have this problem and tried every thing to fix it but no solution! My notebook has Nvidia Geforce GTX150 Ti.

    Any suggestions?
Sign In or Register to comment.